TS-950 low power output.

Just what it says -- this is the place for any discussions not related to Buying, Selling and Trading ham gear. The discussion must be related to Ham Radio.
Post Reply
kf6odc
Posts: 4
Joined: Wed Jun 24, 2009 8:53 pm
Location: Beautiful Sunny San Francisco
Contact:

TS-950 low power output.

Post by kf6odc » Wed Aug 12, 2015 2:53 pm

:cry:

Symptom:
After transmitting for approximately 2 hours at 50% duty with 150 watts output the temperature protection circuit activates reducing the output power to about 50 watts. Normally, full output power will be restored after the fans have had a chance to cool things down. Occasionally the power output will not return to normal, even after extended receive operations.

Cause:
The temperature sensor is attached to the main transformer and is set to activate at 80°C. This setting was selected to reduce power before the internal fuse on the transformer opens.

Correct action:
After through testing, we have found that the temperature sensor should be set to 90°C to allow proper return to full power transmit. This setting will also allow the radio to be used at higher ambient room temperatures without worrying about the power output dropping in the middle of a QSO.

Parts required:

Qty Description Kenwood Part No. Circuit description
1 90°C Thermal switch S59-1416-05 S1
I cant seem to find this part anywhere. Not even Kenwood has it. Please if you can point me in the proper direction i will forever appreciate it..... 8)

KB3LMV
Posts: 45
Joined: Sun May 31, 2009 2:40 am
Location: Melrose Fl.

Re: TS-950 low power output.

Post by KB3LMV » Thu Aug 13, 2015 4:33 pm

Hi Doug
Try ken@k3ten.com or N4ATS St Cloud Fl.Both are GREAT TECHs.Bill N4ATS fixed my TS-690S disolay problem that Kenwood West coast service couldn't find,bad solder joints on caps.
73 & good luck
Paul KB3LMV N.Fl
Paul KB3LMV

kf6odc
Posts: 4
Joined: Wed Jun 24, 2009 8:53 pm
Location: Beautiful Sunny San Francisco
Contact:

Re: TS-950 low power output.

Post by kf6odc » Fri Aug 14, 2015 1:27 am

Thanks Doug, I will keep the info you passed me. If worse come to worse might just have to go that route...

kf6odc
Posts: 4
Joined: Wed Jun 24, 2009 8:53 pm
Location: Beautiful Sunny San Francisco
Contact:

Re: TS-950 low power output.

Post by kf6odc » Fri Aug 14, 2015 3:40 am

This symptom only happens on AM. No other modes are Affected

Post Reply