Search found 3 matches

by steve kc7byp
Sat Oct 25, 2014 9:00 am
Forum: Stolen Equipment
Topic: re: a stolen diamond mobile antenna
Replies: 0
Views: 1844

re: a stolen diamond mobile antenna

This took place sometime late Thur- early Friday morning at my home QTH. Someone took my Diamond CR8900A quad band (10m,6m,2m,70cm) mobile antenna off the back of my 1997 dark blue Chrysler Town & Country minivan. If anyone tries to sell you a kind of ruff looking quad band mobile antenna with a sma...
by steve kc7byp
Wed Aug 27, 2014 6:45 am
Forum: Feedback Forum
Topic: topic, ppl using an others call on the internet
Replies: 0
Views: 448

topic, ppl using an others call on the internet

I don't know if this is the right forum for this post. I put out the following ad looking for parts. ----- Need parts 4 a Allied AX-190 I need the 3 fet's in the receive front end. The fet part number is 2SK19 (or a MPF-101 will work also). Does anyone have them in there junk draw that they can spar...
by steve kc7byp
Wed Mar 08, 2006 5:56 am
Forum: Free For All -- Talk about anything related to Ham Radio.
Topic: I need some help repairing a 1st gen ft-101
Replies: 1
Views: 1489

I need some help repairing a 1st gen ft-101

1 Were on the radio's meter is 60 ma for the transmit ideal bios current spouse to be? There is no 60 ma mark on the meter. I also have a Swan 350 that works great on all bands that I am using for testing. 2 The rig is transmitting and reviving very good on 80 and 40 meters. The Receiver works good ...